"Pretty URLs" breaking links

Having a problem getting Nova installed? Can't figure out why something isn't working right? This is the place to get help and report any bugs you find with Nova!

Bomoor Sun Aug 05, 2018 1:05 pm

"Pretty URLs" breaking links

Hello there,

I have been looking back over the board and cannot see an answer for this.

When following the instructions for the "Pretty URLs" seen here, it works fine except it breaks all the image links that use special characters such as spaces, underscores or even use capital letters in the link when they should be lower case (or vice versa).

For example, where before codeigniter would allow "image file.png", for a an image called "image_file.png", it no longer does. I wonder if the .htaccess file is stopping the code in the nova_config.php file to run? I placed the "$config[‘index_page’] = “”" code in but I am not sure if I did it right. This is my current config.php file:

Code: Select all
<?php if ( ! defined('BASEPATH')) exit('No direct script access allowed');

require_once MODPATH.'core/config/nova_config.php';
$config['index_page'] = "";


I think it is probably not to do with this and rather because the .htaccess file is now causing the site to look for exact links, rather than allowing links with similar characters.

We may just have to be more precise with our links from now on but it was nice when it was more forgiving! Any advise would be appreciated.
User avatar

Posts: 7


Return to Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron