Installation Issue

Having a problem getting Nova installed? Can't figure out why something isn't working right? This is the place to get help and report any bugs you find with Nova!

AlekiaNuroz Thu Dec 07, 2017 4:54 pm

Installation Issue

Hello. I've begun trying to install version 2.4.10 and have encountered the following error:


Code: Select all
Fatal error: Uncaught Error: Call to undefined method CI_Loader::module() in /var/www/html/nova/modules/core/libraries/Nova_user_panel.php:20 Stack trace: #0 /var/www/html/nova/ci/core/Loader.php(1100): Nova_user_panel->__construct() #1 /var/www/html/nova/ci/core/Loader.php(976): CI_Loader->_ci_init_class('user_panel', '', NULL, NULL) #2 /var/www/html/nova/ci/core/Loader.php(217): CI_Loader->_ci_load_class('User_panel', NULL, NULL) #3 /var/www/html/nova/ci/core/Loader.php(1179): CI_Loader->library('user_panel') #4 /var/www/html/nova/ci/core/Loader.php(153): CI_Loader->_ci_autoloader() #5 /var/www/html/nova/ci/core/Controller.php(52): CI_Loader->initialize() #6 /var/www/html/nova/modules/core/libraries/Nova_controller_main.php(45): CI_Controller->__construct() #7 /var/www/html/nova/modules/core/controllers/nova_main.php(17): Nova_controller_main->__construct() #8 /var/www/html/application/controllers/main.php(9): Nova_main->__construct() #9 /var/www/html/nova/ci/core/CodeIgniter.php(309): Main->__construct() #10 /var/www/h in /var/www/html/nova/modules/core/libraries/Nova_user_panel.php on line 20


Site url: http://starbase242.ca

All I have done is copied the files over to the server and navigated to the URL

Posts: 3


AgentPhoenix Fri Dec 08, 2017 2:47 pm

Re: Installation Issue

Do you know what version of PHP your server is running?
User avatar

Posts: 7531


AlekiaNuroz Fri Dec 08, 2017 8:19 pm

Re: Installation Issue

Version 7.0.22

Posts: 3


AgentPhoenix Sat Dec 09, 2017 10:57 am

Re: Installation Issue

It's possible that it's a PHP 7 issue. Nova 2 doesn't play particularly nice with PHP 7, but I don't remember exactly what the issues were.

I've got a bit of a crazy weekend ahead of me, but I can definitely do some testing Sunday night or Monday and see if I can reproduce the issue and give you a workaround.
User avatar

Posts: 7531


AlekiaNuroz Thu Jan 04, 2018 2:05 pm

Re: Installation Issue

Now that I'm back from vacation, I was wondering if there was any resolution to this issue thus far?

Posts: 3



Return to Help

Who is online

Users browsing this forum: No registered users and 2 guests