TLS/SSL connection not working for smtp mail.

Having a problem getting Nova installed? Can't figure out why something isn't working right? This is the place to get help and report any bugs you find with Nova!

DeathKitten Fri Mar 31, 2017 1:09 am

TLS/SSL connection not working for smtp mail.

So, I decided to try using smtp instead of letting the server send nova mail, because I'd started getting some issues with multiple players' emails recently and they weren't the sort that emailing dreamhost to talk to the other isp to clear it up was really going to work.

Well, I set the email config file like this:

Code: Select all
$config['useragent']      = 'CodeIgniter';
$config['protocol']      = 'smtp';
$config['mailpath']      = '/usr/sbin/sendmail';
$config['smtp_host']      = 'sub4.mail.dreamhost.com';
$config['smtp_user']      = 'nova@spark.deathkitten.net';
$config['smtp_pass']      = '*******************';
$config['smtp_port']      = '465';
$config['smtp_timeout']      = 5;
$config['smtp_crypto']      = "ssl";
$config['wordwrap']      = FALSE;
$config['wrapchars']      = '76';
$config['mailtype']      = 'html';
$config['charset']         = 'utf-8';
$config['validate']      = FALSE;
$config['priority']         = '3';
$config['crlf']         = "\n";
$config['newline']      = "\n";
$config['bcc_batch_mode']   = FALSE;
$config['bcc_batch_size']      = 200;


This gives me the following error message:

Code: Select all
Fatal error: Uncaught exception 'Swift_TransportException' with message 'Connection to sub4.mail.dreamhost.com:465 Timed Out' in /home/deathkitten/prima-vista.brassfrog.net/nova/modules/swiftmailer/classes/Swift/Transport/AbstractSmtpTransport.php:404 Stack trace: #0 /home/deathkitten/prima-vista.brassfrog.net/nova/modules/swiftmailer/classes/Swift/Transport/AbstractSmtpTransport.php(289): Swift_Transport_AbstractSmtpTransport->_getFullResponse(0) #1 /home/deathkitten/prima-vista.brassfrog.net/nova/modules/swiftmailer/classes/Swift/Transport/AbstractSmtpTransport.php(117): Swift_Transport_AbstractSmtpTransport->_readGreeting() #2 /home/deathkitten/prima-vista.brassfrog.net/nova/modules/swiftmailer/classes/Swift/Mailer.php(79): Swift_Transport_AbstractSmtpTransport->start() #3 /home/deathkitten/prima-vista.brassfrog.net/nova/modules/core/libraries/Nova_mail.php(162): Swift_Mailer->send(Object(Swift_Message)) #4 /home/deathkitten/prima-vista.brassfrog.net/nova/modules/core/controllers/nova_write.php(2642): Nova_mail->send() in /home/deathkitten/prima-vista.brassfrog.net/nova/modules/swiftmailer/classes/Swift/Transport/AbstractSmtpTransport.php on line 404


But if I go back to the config file and change to port 25, everything seems to work. As that's the plain text port, I really don't want to use that. I want to use TLS/SSL for my connection. I added the smtp_crypto variable to try and fix it, but regardless of if I put in ssl or tls, it gives me the error message with double quotes, and just a blank page if I use single quotes instead.

Any idea what's going on? This is on my test nova, not my primary, so I'm not down but I'd really like to get this change in place on my live install and see if it clears up some of my issues.
Captain Amelia Waterhouse of the USS Joshua Norton, a Clandestine Operations sim.

Come chat with us on Discord! discord.gg/3bUmudQ
User avatar

Posts: 55


AgentPhoenix Fri Mar 31, 2017 6:41 am

Re: TLS/SSL connection not working for smtp mail.

You'll need to talk to the host about why you aren't able to connect to the SMTP over TLS/SSL because I think it's working over those formats for other people.

If you do talk to them, definitely report back about what they say.
User avatar

Posts: 7557



Return to Help

Who is online

Users browsing this forum: No registered users and 3 guests

cron